Service Disruption

Incident Report for PDCflow

Resolved

The system is operating normally, and we will continue to monitor it to help prevent any further interruptions.
Posted Mar 06, 2026 - 13:54 MST

Monitoring

Services have been restored, and PDCflow systems are now operating normally. Our team will continue to monitor performance closely to ensure ongoing stability.
Posted Mar 06, 2026 - 10:12 MST

Investigating

We are currently investigating an issue affecting PDCflow services.

Our team is actively working to identify the cause and implement a solution. Updates will be provided as more information becomes available.
Posted Mar 06, 2026 - 09:59 MST
This incident affected: Credit Card Processing Service, eCheck Processing Service, Flow Service, PDCflow User Interface, Network Connectivity and API Services (GW Authentication, Company Administration Service, IVR Service, Notification Service, Portal, Schedule Service, Transaction Service, Secure Overlay, Signature Service, Tokenization Service, Transaction Inquiry, eCheck, Credit Card, Auth Signature Audit, Auth Signature, Texting Service).