Payment service disruption

Incident Report for PDCflow

Resolved

This incident has been resolved.
Posted Nov 29, 2021 - 10:45 MST

Monitoring

The issue has been corrected and payments are processing successfully at this time.
Posted Nov 29, 2021 - 08:38 MST

Investigating

We are currently investigating an issue preventing payments from processing on the PDCflow platform. We will update as we learn more.
Posted Nov 29, 2021 - 08:07 MST
This incident affected: Credit Card Processing Service, eCheck Processing Service and API Services (Transaction Service, eCheck, Credit Card).