Newtek ZeroCostProcessing Service Disruption
Incident Report for PDCflow
Resolved
This issue has been resolved by Newtek, and all transactions are processing as expected.

We apologize for any inconvenience this may have caused.
Posted Jun 26, 2023 - 11:07 MDT
Investigating
Valued Customer,

We are currently experiencing a service disruption that is affecting our Newtek ZeroCostProcessing users.

Our development team is working with the Newtek team to identify the root cause and implement a solution.

We will send an additional update as soon as we have more information.
Posted Jun 26, 2023 - 09:44 MDT
This incident affected: Credit Card Processing Service.