PDCflow - Partial Disruption to Consumer Portals
Incident Report for PDCflow
Resolved
Valued Customer,

The issue affecting consumer portals has been resolved. All consumer portals are processing as expected.

We apologize for any inconvenience this may have caused.
Posted Nov 20, 2024 - 09:44 MST
Identified
Our development team has identified the root cause of the issue and is implementing a solution now.
Posted Nov 20, 2024 - 09:39 MST
Investigating
Valued Customer,

We are currently experiencing a partial disruption to our consumer portals.

Our development team is working to identify the root cause and implement a solution.

We will send an additional update as soon as we have more information.
Posted Nov 19, 2024 - 19:00 MST
This incident affected: PDCflow User Interface.