Our upstream provider has verified the issue has been corrected and resolved.
Posted Sep 02, 2026 - 12:50 MDT
Update
Update — September 2, 2026, 10:24 AM Status: Monitoring
Our upstream provider has identified the issue and is working on a resolution.
We'll post another update as the provider's fix progresses, or within 60 minutes.
Posted Sep 02, 2026 - 10:44 MDT
Investigating
Status: Degraded Performance — Card Transaction Processing Started: September 2, 2026, 6:56 AM PDT Status: Investigating / Monitoring
What's happening We are seeing degraded performance from an upstream payment processing provider. Some card transactions submitted through PDCflow may fail or take longer than usual to complete.
What's affected - Card transactions
What we're doing The provider has identified connectivity issues and is working on a resolution now. We are monitoring transaction success rates and will post an update as soon as we have new information, or within 60 minutes, whichever comes first.
We'll update this notice when the issue is resolved.
Posted Sep 02, 2026 - 08:49 MDT
This incident affected: Credit Card Processing Service.