PDCflow not impacted by Crowdstrike
Incident Report for PDCflow
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 11:44 MDT
Monitoring
With the large and ongoing outage regarding Crowdstrike/Microsoft. We would like to notify our customers that this is not impacting PDCflow. Currently, all our partners and processors are operating normally. We'll update you immediately if any issues arise.

Thank you PDCflow
Posted Jul 19, 2024 - 12:12 MDT