Card Gateway Outage - Partial Interruptions

Incident Report for PDCflow

Resolved

Our Card Processing Gateway Provider has reported stable processing.

We will continue to monitor and provide updates if the status changes.

We apologize for any inconvenience this may have caused.
Posted Dec 02, 2025 - 16:59 MST

Identified

Valued Customer,

Our Card Processing Gateway Provider is experiencing a partial disruption affecting Card processing services.

We are seeing a high rate of "Fraud verification module" errors from our card processing gateway provider.

We are currently investigating the issue and apologize for the inconvenience.
Posted Dec 02, 2025 - 16:50 MST
This incident affected: Credit Card Processing Service.