We have received notice that a fix to prevent any additional transactions from batching has been released.
Unfortunately, this fix does not retroactively find the already affected transactions to fix them.
USAePay is still asking that you review your recent deposits and notify us (via email: support@pdcflow.com) of any unexpected discrepancies or if you have any concerns. Only then will we be able to work directly with USAePay to manually batch out any affected transactions with your next live batch to resolve the issue.
If USAePay is not your backend gateway provider, no action is needed on your part.
Thank you.
Posted Apr 23, 2026 - 11:41 MDT
Identified
We have been notified by USAePay of a system issue that is causing sporadic transactions to not be batched out as expected. This issue has been found to date back as far back as March 22, 2026 (possibly further), and is still ongoing. Please note that not all transactions processed since that date have been affected.
USAePay is actively investigating the issue; however, they are unable to proactively identify all affected accounts or transactions at this time. As a result, we ask that you review your recent deposits and notify us (via email: support@pdcflow.com) of any unexpected discrepancies or if you have any concerns.
Once you alert us, we will work directly with USAePay to manually batch out any affected transactions with your next live batch to resolve the issue.
If USAePay is not your backend gateway provider, no action is needed on your part.
We sincerely apologize for the inconvenience this may cause to you and your customers. Please don't hesitate to reach out to us with any questions.
Posted Apr 22, 2026 - 14:59 MDT
This incident affects: Credit Card Processing Service.