We are continuing to monitor for any further issues.
Posted Nov 28, 2025 - 09:48 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2025 - 08:08 MST
Investigating
Hosted payment portals are currently offline due to a security incident. We have taken the portals down as a precautionary measure to protect our environment while we investigate. We are working to resolve the issue and will restore service as soon as possible. All other services remain fully operational.