System latency
Incident Report for PDCflow
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 13:28 MDT
Monitoring
The fix has been completed and payment processing has been turned back on.
Posted Apr 29, 2021 - 11:13 MDT
Update
Payment processing has been temporarily taken offline to implement the required fix.
Posted Apr 29, 2021 - 10:29 MDT
Identified
We are currently experiencing high latency on transactions which is impacting some payments. We have identified the issue and are currently implementing a fix.
Posted Apr 29, 2021 - 10:07 MDT
This incident affected: Credit Card Processing Service, eCheck Processing Service and API Services (Transaction Service, eCheck, Credit Card).