PDCflow - Partial Disruption
Incident Report for PDCflow
Resolved
Credit Card Processing Services are fully operational.

Between 8:12–9:11 am MST a small set of credit card transactions were submitted for processing but weren’t accessible in reporting. Those credit card transaction records have now been corrected and added into reporting. We apologize for any inconvenience this may have caused.
Posted Jul 20, 2022 - 12:37 MDT
Identified
Credit card processing has returned to normal. We are currently working to address impacted credit card reporting.
Posted Jul 20, 2022 - 09:35 MDT
Investigating
Valued Customer,

We are currently experiencing a partial disruption to credit card services.

Our development team is working to identify the root cause and implement a solution. Credit Card users may be affected.

We will send an additional update as soon as we have more information.
Posted Jul 20, 2022 - 09:10 MDT
This incident affected: Credit Card Processing Service.