Payrazr ACH service

Incident Report for PDCflow

Resolved

This incident has been resolved.
Posted Nov 11, 2022 - 13:12 MST

Investigating

The Payrazr ACH service (Billingtree/REPAY) is partially impacted by a connectivity issue. ACH transactions are processing normally, however, ACH status updates are not being received. PDCflow is currently working with REPAY to investigate the issue.
Posted Nov 11, 2022 - 10:19 MST
This incident affected: eCheck Processing Service.