Intermittent Credit Card Processing Failures

Incident Report for PDCflow

Resolved

The incident has been confirmed as resolved.
Posted Mar 16, 2022 - 10:14 MDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 16, 2022 - 10:13 MDT

Identified

USAEpay has acknowledged the issue and is currently working to identify and correct it.
Posted Mar 16, 2022 - 08:24 MDT

Investigating

The USAEpay backend gateway is currently experiencing intermittent failures when processing card transactions. We are investigating the issue with them. This issue is only impacting a subset of transactions.
Posted Mar 16, 2022 - 08:20 MDT
This incident affected: Credit Card Processing Service and API Services (Credit Card).