Newtek ZeroCostProcessing Service Disruption
Incident Report for PDCflow
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 07:47 MST
Update
This issue has been resolved by Newtek, and all transactions are processing as expected.

We apologize for any inconvenience this may have caused.
Posted Dec 04, 2024 - 07:47 MST
Investigating
Valued Customer,

We are currently experiencing a service disruption that is affecting our Newtek ZeroCostProcessing users.

We are working with the Newtek team to identify the root cause and implement a solution.

We will send an additional update as soon as we have more information.
Posted Dec 04, 2024 - 07:24 MST
This incident affected: Credit Card Processing Service.