Email Delivery to Yahoo.com and Aol.com addresses
Incident Report for PDCflow
Resolved
We have confirmed Yahoo.com, and AOL.com email has been delivered as expected since Verizon Media implemented the change yesterday. All PDCflow systems are fully functional.
Posted Jan 29, 2021 - 09:23 MST
Monitoring
Verizon has notified us that the issue has been corrected. We have confirmed that emails are now being delivered as expected. We will continue to monitor delivery and update if the status changes.
Posted Jan 28, 2021 - 13:30 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 28, 2021 - 11:07 MST
Update
Verizon has identified the issue and confirmed that they are working to correct it on their side. We will update when they confirm it is fixed and continue to monitor to ensure the issue is resolved.
Posted Jan 28, 2021 - 11:05 MST
Update
We are continuing to investigate the issue. It does appear to be isolated to Verizon Media, which controls AOL and Yahoo email. Verizon has been notified, and we are working diligently to get the delivery issues resolved.
Posted Jan 27, 2021 - 11:48 MST
Investigating
We are currently investigating increased bounce rates when sending emails to AOL.com and Yahoo.com email addresses.
Posted Jan 26, 2021 - 14:53 MST
This incident affected: Flow Service and API Services (Notification Service, Signature Service).