Newtek - Processor Funding Delay Today Causing Impacts Across Many Financial Institutions
Incident Report for PDCflow
Resolved
Newtek/ Fiserv have released all 4/4 processing deposits to the affected merchants as of today April 8th.

If you have not received funds for 4/4 processing, please submit a support ticket to support@pdcflow.com and we will investigate further.

Thank you for your patience and cooperation and we apologize for the inconvenience this has caused to you and your customers.
Posted Apr 08, 2022 - 11:21 MDT
Update
PDCflow received an update from Newtek that Fiserv has scheduled to recover the credit sales and return transactions that were excluded from April 5, 2022 in tonight's processing, Thursday April 7, 2022.

PDCflow will continue to update this status page with updates provided by Newtek.

Thank you for your patience and cooperation and we apologize for the inconvenience this has caused to you and your customers.
Posted Apr 07, 2022 - 15:28 MDT
Monitoring
Newtek has started to process the missing deposits as of today April 7th and expect all funds to deposit no later than tomorrow morning (April 8th).

PDCflow will continue to update this status page with updates provided by Newtek.

Thank you for your patience and cooperation and we apologize for the inconvenience this has caused to you and your customers.
Posted Apr 07, 2022 - 14:15 MDT
Update
Newtek continues to work directly with Fiserv today on the restoration of the account funding impacts from the Tuesday, April 4th payment processing activity. The goal is to process the restoration sometime today which will be provided into accounts no later than tomorrow morning, Friday, April 8th. Fiserv has confirmed that Wednesday's payment processing funding was completed and distributed as normal with no issues.

PDCflow will continue to update this status page with updates provided by Newtek.

Thank you for your patience and cooperation and we apologize for the inconvenience this has caused to you and your customers.
Posted Apr 07, 2022 - 11:49 MDT
Identified
We have been notified that Fiserv has had a systemic issue with processing funding through some of their banking relationships. Newtek and PDCflow are currently awaiting updates about when this issue will be resolved and when funding will be provided.

If you merchant service provider is not Newtek, you may disregard this message.
Posted Apr 06, 2022 - 15:00 MDT
This incident affected: Credit Card Processing Service.