ACH Processing via Payliance
Incident Report for PDCflow
Resolved
This incident has been resolved.
Posted May 24, 2021 - 12:15 MDT
Monitoring
ACH payments are now processing normally at Payliance. We will continue to monitor and provide updates if the status changes.
Posted May 24, 2021 - 07:56 MDT
Investigating
We are currently investigating a high amount of errors when processing ACH via Payliance.
Posted May 24, 2021 - 07:38 MDT
This incident affected: eCheck Processing Service and API Services (Transaction Service, eCheck).